browser bar

DevTrace free

Our free Ruby on Rails Development profiler gives instant feedback on your app's bottlenecks while you code.

DevTrace is included in our gem: just add
gem 'scout_apm' to your Gemfile and run SCOUT_DEV_TRACE=true rails server locally.

Captures every request, including AJAX

React, Angular, Backbone, Ember - it doesn't matter. DevTrace's framework-agnostic request detection doesn't miss a beat in complex single-page apps.

Instruments popular Ruby gems

DevTrace leverages Scout's instrumentation library, automatically instrumenting ActiveRecord, Mongo, Redis, ElasticSearch, Net::HTTP and more.

Slow database query analysis

DevTrace hunts down expensive N+1 queries, tracks the number of ActiveRecord rows returned, and provides backtraces to locate the source of slow queries.

Identifies memory bloat

DevTrace instruments object allocations in addition to timing metrics: easily identify memory hotspots in your code.

Share traces with your team

Complex performance decisions are made as a team: easily share traces with your partners in performance.

Track slow calls to a line-of-code

Measuring is ½ the battle: DevTraces provides backtraces to the in-app source of slow method calls so you can easily address slow hotspots.

Undetectable overhead

Our tracing technology is engineered for high-throughput, mission-critical apps. DevTrace adds virtually undetectable overhead to your development cycle.

Unobtrusive UI

Our speed badge doesn't take over your valuable $(window) space: it's easily ignorable when you don't need it yet always there when things are slow.

No signup required

Just add scout_apm to your Gemfile and start performance-ing. No logins. No email capture.

Installing DevTrace

1Install our gem.

Your Gemfile:

gem 'scout_apm'

Shell:

bundle install

2 Start your Rails app with the SCOUT_DEV_TRACE environment variable.

SCOUT_DEV_TRACE=true rails server

3 ⌘+R your browser and look for the speed badge!

DevTrace supports Ruby 1.8.7+ and Rails 2.2+. Memory instrumentation Requires Ruby 2.1+.

  Stuck? Email us at support@scoutapp.com.